Back to overview
Maintenance
Systems Upgrades
May 19, 2026 at 1:17am UTC
–
May 19, 2026 at 4:17am UTC
Affected services
app.scitrera.ai
Resolved
May 19, 2026 at 4:17am UTC
Maintenance ended
Affected services
Created
May 19, 2026 at 1:17am UTC
Will be upgrading systems during this time, there will be intermittent connectivity issues during this window.
Affected services